Commander One - Crash at startup(Read 13163 times)
Commander One - Crash at startup on: October 25, 2017, 11:00:38 AM
I just installed CO (the free version with PRO activated for a few days). All good, I configured it as I like it, was very excited about it, first TC-clone that actually looks good and works on a MAC and it's not a shitty java app.

But, after playing with more options, I tried the root-mode, CO restarted in a new window. I closed it and tried to get back to the normal user app.... and all hell broke loose from now on.

The app won't start anymore, I deleted it and reinstalled, same result. I'm getting that dialog saying that CO quit last time and if I want to reopen the windows again. No matter what I choose, Reopen/Don't Reopen, the app crashes and I get the standard Apple dialog: Ignore/Report/Reopen.

Launching the app with sudo "..."  works fine.

So, what can I do to make it work again and, ideally, not lose all the configs I did ?

Re: Commander One - Crash at startup Reply #1 on: October 25, 2017, 09:55:42 PM
No one ?
It's probably a messed up config, any ideas where I can find all the config files or whatever else the app uses ?
Deleting the app file doesn't work, something is persisted in another place.

LE: Isn't there anyone from Eltima to answer my question ? I actually want to use this app and pay for the PRO features, but if this is the response time for a major issue... I'm not so sure anymore.
« Last Edit: October 27, 2017, 08:46:58 AM by crocodiluQ »

Re: Commander One - Crash at startup Reply #2 on: November 02, 2017, 10:05:30 AM

We are sorry for the late reply. The reason of it is that we were investigating this case and unfortunately we were unable to reproduce the issue on our side.

In order to troubleshoot this problem please provide us with some additional information:

1. Specify your account type (admin or normal);

2. Please reboot your system if you didn't do that yet;

3. Backup your settings in ~/Library/Preferences/
- if you didn't set up the connections (Dropbox, FTP etc.) then just copy file com.eltima.cmd1.plist
- if you did set up then copy all the files that begin with com.eltima ;

4. Delete the settings by running defaults delete com.eltima.cmd1 in Terminal
Please perform the procedure using sudo command and normal user;

5. Restart your system;

6. Replace the files from paragraph 3 in ~/Library/Preferences/ ;

7. Run a command 'defaults read -file_location-' (please replace -file location- with a full path to the files from the paragraph 6);

8. Restart Commander One.

Re: Commander One - Crash at startup Reply #3 on: November 03, 2017, 05:23:28 PM
Still no.

1) Admin
2) Rebooted a bunch of times already.
3) Let's assume I don't want to save anything, just to make it work.
- defaults delete (running it again with sudo is not needed, it just says the domain no longer exists)
- manually delete the com.eltima files from /Library/Preferences
- reboot
- delete the app
- reinstall

Same crash, plist preferences files are back, exactly as they were before. (same account in the dropbox plist for example). 
I'm not 100% familiar with this Preferences plists and defaults from Apple, but how are those recreated back with that same information ?
Seems to me we're not removing the root of the problem, just some bunch of settings and files that are recreated when running the app again.

Where else do you keep files or configs ?

Basically, how can I remove the app completely. It's more than an app file and some plists.

Re: Commander One - Crash at startup Reply #4 on: November 06, 2017, 08:14:01 AM
Can you please not investigate again for 1 week before responding ? :)

Just tell me how to 100% remove the app, so that when I reinstall the app, the plists are not recreated again with my exact values I just set before (like the dropbox account....).

So a COMPLETE app removal, from everywhere.

Re: Commander One - Crash at startup Reply #5 on: November 06, 2017, 09:29:43 AM

* Please check this folder ~/Library/Services , and if there are any files in it then try deleting/moving them to any other folder and launch Commander One.

* We would kindly ask you to add a new user on your computer and check if this problem occurs when using the new user account.

Re: Commander One - Crash at startup Reply #6 on: November 06, 2017, 05:58:37 PM
- the ~/Library/Services folder is empty

Doing another test now:

- deleted the app from /Applications
- deleted the defaults (from terminal, also files on ~/Library/Preferences)
- restart, double check to make sure they didn't appear back.
- created a new user, downloaded commander.dmg again, install, of course it works (told you before it also works with sudo / root)
- went back to my user (Admin) -> same issue BUT the plist files are finally fresh (no more my account in the dropbox plist one...)
- I also deleted the files from ~/Library/Saved Application State and at least I'm not getting that dialog with Reopen or not the windows.

So basically, back to square one, new plists created when running the app, but app still crashes with this user. What else can I do ?

Re: Commander One - Crash at startup Reply #7 on: November 07, 2017, 05:34:59 PM
Please open Terminal and execute this command in order to clean Launch Services Database:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

Re: Commander One - Crash at startup Reply #8 on: November 07, 2017, 07:53:46 PM
Same thing after running that.
Getting the dialog asking if the app should automatically check for new updates and immediately the dialog where Commander One quit unexpectedly.

Re: Commander One - Crash at startup Reply #9 on: November 12, 2017, 07:58:55 AM
No other ideas ?

There are many ways to investigate this, from SDKs like Crashlytics and so on, I'm sure you have something like this implemented. Can't you see my crash somewhere and determine what's causing it ?

Re: Commander One - Crash at startup Reply #10 on: November 13, 2017, 04:20:29 PM

 We are sorry for the delay. Our developers' team will need some more time to investigate this issue. We will get back to you as soon as possible.
Hope for your understanding in this matter.

Re: Commander One - Crash at startup Reply #11 on: March 30, 2018, 10:48:29 AM

We would recommend you to contact the GraphX support team so that they could help you solve the issue since Commander One app has nothing to do with the crash.


Sitemap 1 2 3 4 5