Call of Duty 2(Read 22767 times)
Call of Duty 2 on: December 30, 2008, 10:14:24 PM

We have multiple servers with Windows Server 2003 Standard (SP3) on it. When I try to run Call of Duty 2 as service with Application-as-service, it won't start. As soon as I create a shortcut to CoD2MP_s.exe and give my parameters, it runs without a problem.

My parameters:
+set dedicated 2 +pb_sv_enable +wait +set sv_punkbuster 1 +set sv_maxclients 16 +set net_ip xx.xx.xx.xx +set net port 28960 +exec server.cfg +map_rotate

This problem occurs on all our Windows 2003 servers and we tried Service-O-Matic and Application-as-service both, but both with the same problem. Call of Duty (1) and Call of Duty 4 are just running as they should with Application-as-service.

Are there Call of Duty 2 admins on this forum with a solution for my problem? :)

Kind regards,


Re: Call of Duty 2 Reply #1 on: January 05, 2009, 01:14:30 PM
Hello Jasper,

We are ready to help you and willing to do so very much. I kindly ask you to be more specific. Please, let us know what you mean exactly by "it won't start". Could you please specify your step-by-step actions, what exactly you do and where, so we can reproduce your actions and see where exactly the problem occurs. Please, specify your system's properties.

Re: Call of Duty 2 Reply #2 on: January 19, 2009, 10:12:31 PM
Hello Tina,

Thanks for your reply.

When I run the gameserver "by hand" (create a shortcut to the executable and give the parameters), it starts up the gameserver software, and the gameserver comes online. When I look in the task manager, I see the memory usage rise to 120MB, which is a good sign.

When I run the gameserver in AaS (default settings, only defined the executable, parameters (see startpost) and display name) the gameserver doesn't come up. When I look in the task manager, the memory usage is only 7MB, so it's hanging somewhere.

All our servers are running on Dell hardware (most of them are PowerEdge 1750's, 2x Xeon 3.06GHz, 2GB memory, 2x 36GB SCSI, Windows Server 2003 Std. (SP3)).

Please let me know if you need more details.

Kind regards,


Re: Call of Duty 2 Reply #3 on: January 21, 2009, 09:44:28 AM
Hello Jasper,

Please, try to launch your application not from the "LocalSystem" user account.

Please, go to the Service tab -> System Account -> Account -> Select User… select user account which works properly with your service.

Note, that it is necessary to set Password for this user account.

Re: Call of Duty 2 Reply #4 on: January 21, 2009, 09:56:45 AM
Hello Tina,

I already tried this, but this doesn't seem to work.

Kind regards,


Re: Call of Duty 2 Reply #5 on: January 22, 2009, 06:28:46 PM
Dear Jasper,

Please, send us your XML configuration file to


Sitemap 1 2 3 4 5