Incompatibility between RegVSP and u3dapi10.dll(Read 14569 times)
Incompatibility between RegVSP and u3dapi10.dll on: October 15, 2008, 02:38:53 PM

I recently bought an hardware device which use your virtual serial ports program, and faced an installation issue on my new computer.

Actually, the installation of the software package provided by the manufacturer of this device was hanging just after the closing of vbsetup.exe. I had to kill the install process, and noticed in the task manager an instance of regVSP.exe, which was hung. Of course, I couldn't create any virtual serial port, and my device was totally useless :-(

After several hours examination of logs provided by RegMon and FileMon, it appeared that the presence of u3dapi10.dll (installed by TortoiseCVS, and located in the CVSNT directory) was the cause of this malfunction ! Renaming it ( for example) did the trick !

You can rename it back to its original name after the install, but you must keep in mind you'll have to do it again when installing an updated version, or for uninstallation.

To be honest, I can't say exactly what is happening (I'm sure the Eltima developers could explain it more precisely), but I just wanted to inform you abt that, considering the hours I spent on it ;-)

FYI, I'm using XP Home SP3.


Re: Incompatibility between RegVSP and u3dapi10.dll Reply #1 on: October 17, 2008, 03:22:30 PM

Thank you for contacting us.
We are more than eager to investigate the problem and fix the bug if there is any.  I regret to say that our testers were not able to reproduce the problem you described.

I kindly ask you to address this report to support team of the company which manufactured your device. Please, ask them to contact us.

Re: Incompatibility between RegVSP and u3dapi10.dll Reply #2 on: January 14, 2010, 06:22:57 PM
I have found the same problem. I've got TortoiseCVS installed, and spent ages trying to install the ActiveX control but the installer just kept hanging on RegVSP. I tried what the previous poster suggested by changing u3dapi10.dll and it works now.


Sitemap 1 2 3 4 5